Laravel7でlaravel/uiをインストールした際に発生したエラーと対応内容

スポンサーリンク

Laravel7 でlaravel/uiをcomposerでインストールしようとしたら、エラーが発生してしまったので、エラー内容と対応した方法を記載していきます。

Laravel7インストール

すでにLaravel のバージョン8がリリースされてますので、今回はバージョン指定でインストールします。


$ composer create-project --prefer-dist laravel/laravel:^7 test-project

インストールが完了したら、次は、Laravel/uiをインストールします。

laravel/uiインストール時のエラー内容


$ composer require laravel/ui

すると。。。以下のエラーが発生しました。


Using version ^3.0 for laravel/ui
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: remove laravel/framework v7.28.2
    - Conclusion: don't install laravel/framework v7.28.2
    - laravel/ui 3.x-dev requires illuminate/filesystem ^8.0 -> satisfiable by illuminate/filesystem[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.2.0, v8.3.0].
    - laravel/ui v3.0.0 requires illuminate/filesystem ^8.0 -> satisfiable by illuminate/filesystem[8.x-dev, v8.0.0, v8.0.1, v8.0.2, v8.0.3, v8.0.4, v8.1.0, v8.2.0, v8.3.0].
    - don't install illuminate/filesystem 8.x-dev|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.0.0|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.0.1|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.0.2|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.0.3|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.0.4|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.1.0|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.2.0|don't install laravel/framework v7.28.2
    - don't install illuminate/filesystem v8.3.0|don't install laravel/framework v7.28.2
    - Installation request for laravel/framework (locked at v7.28.2, required as ^7.24) -> satisfiable by laravel/framework[v7.28.2].
    - Installation request for laravel/ui ^3.0 -> satisfiable by laravel/ui[3.x-dev, v3.0.0].


Installation failed, reverting ./composer.json to its original content.

どうやら、Laravel/uiのバージョン3.Xをインストールしようとしてるけど、Laravel関連の依存関係パッケージが古くて、インストールができないみたいです。。。

対応方法

Laravel8がリリースされたことで、バージョン8に対応するバージョンのLaravel/uiをインストールとなっているから発生しているみたいなので、Laravel/uiのバージョンを2.Xに落としてインストールします。


$ composer require laravel/ui 2.*

すると問題なくインストールすることができました!

コメント

タイトルとURLをコピーしました